BFR June
Results 1 to 3 of 3

Thread: Sterling sound fades to lame

  1. #1

    User Info Menu

    Sterling sound fades to lame

    Just acquired 2001 Sterling 4H. Plug it in and all is fine for about 10-15 seconds then the sound fades a bit and becomes anemic. Unplug for a while, try again, same result. All controls operate normally but it sounds compressed with no balls and a bit less gain than normal. Battery replaced, pots, switch and jack connections cleaned. Visual inspection reveals nothing out of the ordinary. Tested with multiple amps and cables.

    Any ideas before I start shotgunning components? Is there a component layout available for the PCB or is that super-secret EBMM stuff?

    Thanks for any help!

  2. #2

    User Info Menu

    Your best bet is to try Customer Services, as they'll have more information than anyone here and you could end up being given information that will be counter-productive.
    "this place would be a paradise tomorrow, if every department had a supervisor with a sub-machine gun"

    Monkey Likey

  3. #3

    User Info Menu

    Yeah, definitely customer service. Could be a bad cap or something.
    2007 Stingray 5 HS Cherry Burst / Maple FB / 3 Band EQ / Ceramic Pickups
    2012 Stingray 5 H Pearl Blue / Rosewood FB / 3 Band EQ/ AlNiCo Pickup
    2012 Steve Morse Morse Blueburst / Rosewood FB
    2012 Luke III SSH Vintage Sunburst / Rosewood Neck

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Ernie Ball Forums