VPJr Tuner
Results 1 to 12 of 12

Thread: Issues with Piezo, JP Majesty

  1. #1

    User Info Menu

    Exclamation Issues with Piezo, JP Majesty

    Greetings,

    I purchased my Majesty about a month ago and have had nothing but fun and good times with it. Very recently I played a gig that went very smoothly with no issues but when I got home from the gig I decided to pull her out once more and go over some things, and to my amazement the Piezos just stopped worling. The other pick ups are working just fine, but the Piezos are just not working at all.

    Any ideas as to what may have caused this?? It seems to have sprang up out of nowhere, as it was just working perfectly not even 20 minutes beforehand.

    This is what she looks like:

    Issues with Piezo, JP Majesty-untitled-jpg

    and here again with some of my pedals:

    Issues with Piezo, JP Majesty-untitled1-jpg

  2. #2

    User Info Menu

    Gotta start with the simple question...

    Did you check the batteries? I've been burned by this one before (ask AJ). If you leave guitar plugged in, the batteries are "on" the whole time.
    -Spike
    @blueavngr

    2017 Valentine- Starry Night
    2015 JP15 Blueberry (63/300)

    2019 Cutlass SSS Vintage Sunburst

    "I don't sell my guitars-- they are like ex-girlfriends. You get tired with them and toss them to the side... but then, every once in a while… Damn! You really want to play with them again."

  3. #3

    User Info Menu

    Quote Originally Posted by QuietSpike View Post
    Gotta start with the simple question...

    Did you check the batteries? I've been burned by this one before (ask AJ). If you leave guitar plugged in, the batteries are "on" the whole time.
    Yes, and they're fine. The Blue light on the back flashes as normal when I plug in and the Humbuckers are still working, just no Piezo.

  4. #4

    User Info Menu

    If the battery is good, I'd be looking for a funny connection somewhere. Get in touch with customer service, that's what they are there for!

    And welcome to the forum!
    Forum Moderator, Guitar Teacher and Guitar Tech, Folder of Underpants, Stubber of Toes.
    Irish/American in Paris

    Silhouette Special (2005 Buttercream Limited Edition)
    Cutlass HSS (2018 Roasted Special, Ivory White)

    Click here for my Music Man photo albums


    Ernie Ball Customer Service
    Music Man Customer Service

    Remember, there's a "k" in knucklehead.

  5. #5

    User Info Menu

    I feel like you may have accidentally switched it to Stereo mode...

    Did you push and hold the piezo knob for a good 12 seconds or so?
    2015 Sahara Burst JP15 7 Flame
    2014 Diego Blue Albert Lee HH
    2014 Sterling Silver SBMM *Signed* JP-60D
    2013 Plat. Silver JP13 7
    ******ON PRE-ORDER************
    2016 JP16 7, St. Vincent, Valentine, SBMM JP157 & Majesty

  6. #6

    User Info Menu

    Quote Originally Posted by MajtasticVoyage View Post
    I feel like you may have accidentally switched it to Stereo mode...

    Did you push and hold the piezo knob for a good 12 seconds or so?
    That feeling was right, she was in Stereo. Somehow it must have gotten switched in the course of my travels from the gig to my home. Thank you soooo much, I can't even begin to tell you how nervous I was that I may have accidentally broken her.

    One last thing, thank you to everyone who posted here. I appreciate each and every one of you and your input, and I am proud to be a member of such an informative and helpful forum community.

  7. #7

    User Info Menu

    Good job MajtasticVoyage !!
    Local257, 1963

    JP 15
    Peerless MT Maestro
    Majesty
    Parker Mojo
    Parker Delux
    Tele
    Ibanez GB10
    Gretch CG
    Ibanez BTB675
    MM RP112
    Quilter Amps

  8. #8

    User Info Menu

    Awesome! I don't know if I'm more excited that I was right or that you got it figured out

    Cheers!
    2015 Sahara Burst JP15 7 Flame
    2014 Diego Blue Albert Lee HH
    2014 Sterling Silver SBMM *Signed* JP-60D
    2013 Plat. Silver JP13 7
    ******ON PRE-ORDER************
    2016 JP16 7, St. Vincent, Valentine, SBMM JP157 & Majesty

  9. #9

    User Info Menu

    THANK YOU for this post. Just had this happen to me couldn't figure out why the piezo would just stop working from changing the strings. Must have gone into stereo mode when i was taking the pack cover off to adjust the springs.!!!

  10. #10

    User Info Menu

    THANK YOU! Mjakober!


    For using the search function! .

    Welcome to the forum.
    -Spike
    @blueavngr

    2017 Valentine- Starry Night
    2015 JP15 Blueberry (63/300)

    2019 Cutlass SSS Vintage Sunburst

    "I don't sell my guitars-- they are like ex-girlfriends. You get tired with them and toss them to the side... but then, every once in a while… Damn! You really want to play with them again."

  11. #11

    User Info Menu

    Quote Originally Posted by MajtasticVoyage View Post
    I feel like you may have accidentally switched it to Stereo mode...

    Did you push and hold the piezo knob for a good 12 seconds or so?



    Dudeee you are awesome. I was like omg i ***** up and i just red your comment. Yeah it accidentally switched it to Stereo mode. By the way my problem was : I was playing my majesty and my batteries just gone. Then i put new batteries but this time piezo had gone (humbuckers were fine). And when i did your method , everything went well. Thank you sooo much.

  12. #12

    User Info Menu

    Mine too!! Omg thanks for this post. I was freaking out... and I was also stuck in stereo mode.. thank you so much!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Ernie Ball Forums