New Prodigy
Results 1 to 8 of 8

Thread: Majesty keeps cutting out

  1. #1

    User Info Menu

    Majesty keeps cutting out

    Hi,
    I just got my new Majesty (Polar Noir) last week and I absolutely love it. However, last night I was playing and all of a sudden, the sound cuts out. I unplugged my guitar and plugged it back in and it worked but then it happened again about 30 seconds later. I thought it had something to do with my cord or my pedal board but I tried 4 different patch cords and plugged directly into the amp and it still kept happening about every 15 to 30 seconds after I unplug and plug back in.

    Has anyone else experienced this? I'm going to return the guitar today and hopefully there's a quick fix but I really don't want to be without this guitar for any stretch of time.

    Thanks

  2. #2

    User Info Menu

    Tried changing the battery?
    '05 JP6 Desert Gold matching headstock, inlays, piezo
    '06 Silhouette 20th Anniversary (trem, rosewood)
    '06 Bongo Stealth 4HH
    '14 JP7 BFR Rosewood trans black quilt

  3. #3

    User Info Menu

    Quote Originally Posted by Dead-Eye View Post
    Tried changing the battery?
    No, didn't think of that. It would work every time I unplug and plug back in so it didn't cross my mind. I'll give that a shot.

  4. #4

    User Info Menu

    Watch the lights on the backside when you plug it in as well. Blue means battery is good, and amber means they are ready for replacement.
    EBMM Axis Super Sport (Pacific Blue Burst)
    EBMM L3 HH (Olive Gold)
    EBMM L3 HSS Roasted (Bodhi Blue)
    EBMM Silo Special (Blue Dawn)
    EBMM Albert Lee SSS (Sky Blue)
    EBMM Majesty (Iced Crimson)
    EBMM Cutlass (Vintage Turquoise)
    EBMM L3 BFR (Blueberry Burst)
    EBMM Cutlass HSS (Firemist Silver)

    www.TheseGuysLive.com
    Facebook

  5. #5

    User Info Menu

    I returned my Majesty just last week, The piezo started flaking out and then was gone- no sound. Yes I changed the batteries. Yes I cried...

  6. #6

    User Info Menu

    I changed the batteries and that seemed to work...although I don't see any indicator lights on the back. Come to think of it...I was using the piezo a lot the night before, when it stopped working! I better test that out tonight. I really don't want to return this guitar...I can't go back to my old one!

  7. #7

    User Info Menu

    The light on the battery compartment. When you plug the guitar cable into the guitar the light will briefly light flash
    EBMM Axis Super Sport (Pacific Blue Burst)
    EBMM L3 HH (Olive Gold)
    EBMM L3 HSS Roasted (Bodhi Blue)
    EBMM Silo Special (Blue Dawn)
    EBMM Albert Lee SSS (Sky Blue)
    EBMM Majesty (Iced Crimson)
    EBMM Cutlass (Vintage Turquoise)
    EBMM L3 BFR (Blueberry Burst)
    EBMM Cutlass HSS (Firemist Silver)

    www.TheseGuysLive.com
    Facebook

  8. #8

    User Info Menu

    yup it's kinda common to be honest. mine always did it in hot and humid venues.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Ernie Ball Forums