EBMM Stingray bass blue
Results 1 to 7 of 7

Thread: PieZo not working

  1. #1
    Join Date
    Jan 2018
    Posts
    26

    PieZo not working

    PieZo not working-dc8b9f5c-7290-4441-ba53-5e4bf0d59464-jpgPieZo not working-be89c083-2997-4f1d-821b-795ed560b11e-jpgPieZo not working-bf454b02-ef48-4ace-baa5-b5d45677128d-jpgPieZo not working-0aad154e-647d-4afa-b401-27165023c0aa-jpgPieZo not working-9bd849e8-7596-4492-b88e-c99a2178521d-jpg

    Is the grey wire thatís half assed spliced and twisted together the reasons.
    All other cavities and wiring is fine and all ruled out except volume pot ,wire, or little unsoldered wire by my finger


    Thx!

  2. #2
    Join Date
    Jun 2016
    Location
    Tennessee
    Posts
    625
    The “unsoldered wire” looks like the ground wire (if it’s an uninsulated wire, that’s what it is) that should be trapped under the control cavity cover when it’s in place to ground that cover. You can see a little depression in the body between the cavity and that screw hole where that wire has been previously.
    ---------------
    2018 Valentine in Three-tone Burst
    2016 PDN Luke 3 HH in Starry Night
    2016 Valentine in Trans Maroon
    2014 Axis SS Semi-Hollow MM90 with Piezo
    2012 Reflex Game Changer HSH with Piezo
    2006 20th Anniversary Silhouette Hardtail with Piezo

  3. #3
    Join Date
    Jan 2018
    Posts
    26
    Quote Originally Posted by jones4tone View Post
    The ďunsoldered wireĒ looks like the ground wire (if itís an uninsulated wire, thatís what it is) that should be trapped under the control cavity cover when itís in place to ground that cover. You can see a little depression in the body between the cavity and that screw hole where that wire has been previously.

    THX for replying
    So what do I do?

    Do I order a part, bring it to a shop or send to EBMM?Ē

    Or can I fix?

    ThNks

  4. #4
    Join Date
    Aug 2012
    Posts
    1,030
    Did the piezo work previously? Is this a new guitar that you purchased, or did you buy it used?

    Your best option would be to contact customer service to see what they advise. It looks like the guitar may have had modifications done to the electronics, or at least someone messing around in there that didn't exactly know what they were doing.
    2007 Stingray 5 HS Cherry Burst / Maple fretboard / 3 Band EQ / Ceramic Pickups
    2012 Stingray 5 H Pearl Blue / Rosewood Fretboard/ 3 Band EQ/ AlNiCo Pickup
    2012 Steve Morse Signature Morse Blueburst / Rosewood FB
    2012 Luke III SSH Vintage Sunburst / Rosewood Neck

  5. #5
    Join Date
    Jan 2018
    Posts
    26
    Yes, it was
    It’s mine, registered
    I contracted CS, and a drunk tech apparently is the one who installed a pickup(fired from the shop now)
    He knocked something loose
    It’s something there

  6. #6
    Join Date
    Aug 2004
    Location
    Toronto, Canada
    Posts
    10,318
    Best bet is to let the CS guys advise you. Keep in mind they're prepping for the NAMM show, so they may be a bit slow to respond.

  7. #7
    Join Date
    Jan 2018
    Posts
    26
    Thx beej

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Ernie Ball Cables