Ernie Ball Paradigm
Results 1 to 4 of 4

Thread: Having issues with Purple Majesty Monarchy :-(

  1. #1

    User Info Menu

    Help: Having issues with Purple Majesty Monarchy :-(



    Added another guitar to my collection. I'm a long time Gibson Les Paul user and took the plunge. Finally just got this back from the 12th fret here in Portland, OR. But am having some severe issues with my new monarchy majesty. I'm hoping I don't have to send it back.

    First of all, had the guitar setup with 009-046 gauged strings rather than the 10s that this guitar normally came with. My guitar will not stay in tune, the strings just seem way too sloppy. Should I take this back to the 12th fret and see if they can make some adjustments?

    Second, whenever I plug in, my guitar just randomly powers off, then I have to plug it back in to get sound again. This is super annoying as it keeps shorting out like this. It even happens when I switch between the piezo and bridge/neck pickups. I've swapped out several batteries and the issue keeps happening. I also am using a brand new mogami cable. Could it be a wiring issue?

    Third, I've played these majesties at a lot of stores and when I finally got one in my hands at home, it just doesn't feel as comfortable. I just feel like the ergonomics don't work for me. I'm a taller guy 6"4 and have pretty long arms. I feel like I'm holding a ukulele in my lap sometimes lol. Is this normal and does it just take some getting used to? Also take into account, I'm used to a fixed bridge and a beefier guitar in a les paul.

    I'm hoping I can iron out these technical issues, because it really is a beautiful guitar. Love the purple finish on it! Thanks for you help as always.
    Last edited by nels2481; 10-09-2018 at 08:22 PM.

  2. #2

    User Info Menu

    UPDATE: So I've only had this thing for about a month and I think the batteries are what's causing the issue. When I power up my amp, plug in my guitar, the led indicator is blue. However whenever I switch between mono and stereo, the led turns orange...doesn't blink to indicate which mode I'm in. From my understanding, that light should be green when it switches.

    I tried replacing with some other batteries and it did the same thing. I think all the batteries I have laying around in my junk drawer are crapped out lol. I guess I probably should have done some more digging on the forums before I started freaking out. I was just worried I spent $3k on a guitar with faulty wiring.

  3. #3

    User Info Menu

    Congrats - that is stunning!!!!

    I would try a fresh new set of batteries, and if you are still experiencing problems, contact customer support right away.

    As far as the strings go - I would use whatever gauges you normally use, and adjust the guitar accordingly.
    EBMM Axis Super Sport (Pacific Blue Burst)
    EBMM L3 HH (Olive Gold)
    EBMM L3 HSS Roasted (Bodhi Blue)
    EBMM Silo Special (Blue Dawn)
    EBMM Albert Lee SSS (Sky Blue)
    EBMM Majesty (Iced Crimson)
    EBMM Cutlass (Vintage Turquoise)
    EBMM L3 BFR (Blueberry Burst)
    EBMM Cutlass HSS (Firemist Silver)

    www.TheseGuysLive.com
    Facebook

  4. #4

    User Info Menu

    Congratulations, beautiful instrument!!

    JPXI Cardinal Red
    JP12 Cherry Sugar
    JP12 7 Cardinal Red
    JP15 Transluscent Black
    MAJESTY Glacial Frost
    MAJESTY Ferrari Rosso
    ARTISAN MAJESTY 7 Rosso
    MONARCHY MAJESTY 7 Black Knight
    NOMAC MAJESTY Timeworn Matte Silver

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Ernie Ball Forums