• There is a glitch in the forum software and/or configuration that we are still trying to track down. For now, please make sure that the title of your new thread does NOT start with a number (digits). Otherwise, your post will appear to be saved but future attempts to read it will be met with an error message indicating the thread/post cannot be found. ~ admin

ShortyK

New member
Joined
Jan 30, 2020
Messages
2
Hi all. Searched through the forum and didn't find any results for my issue. 2019 St Vincent HH. I am getting a terrible hum in my bridge pickup when running drive pedals. Now I realize these are hot pups, mine is 16.7 ohms, but without the noise gate on my 5150 pedal, it would be unbearable. No ground issues, gets quieter when lowering the volume. Not cables, tubes, not the amp.

Am I stuck, or has anyone swapped out the pickup for a lower output one?

Thanks,
sK
 

Daniel

Well-known member
Joined
Apr 21, 2016
Messages
2,848
Location
San Luis Obispo
Hi all. Searched through the forum and didn't find any results for my issue. 2019 St Vincent HH. I am getting a terrible hum in my bridge pickup when running drive pedals. Now I realize these are hot pups, mine is 16.7 ohms, but without the noise gate on my 5150 pedal, it would be unbearable. No ground issues, gets quieter when lowering the volume. Not cables, tubes, not the amp.

Am I stuck, or has anyone swapped out the pickup for a lower output one?

Thanks,
sK

Hi there,
Sorry to hear that you're having an issue with your St. Vincent bridge pickup. Shoot me an email at [email protected] with a video or audio file of the issue and I'll help you out.
 
Top Bottom